Upgrading Third Party Components for Windows Server

LAMUM is developed using PHP language and Java Struts. These languages depend on other components and services to run. Java needs JDK and JRE to enable the webserver Tomcat to run. PHP is launched using Apache webserver which also needs Microsoft Visual C++ to run. Periodically PHP and other third party components LAMUM uses becomes deprecated. We build our software with the latest components and upgrade its quarterly. If for any reason, the components become vulnerable to security threats before an upgrade, we usually advise the clients to do the individual components upgrade. Below, you will find a write up on how to upgrade the individual components.